Vous êtes nouveau sur Developpez.com ? Créez votre compte ou connectez-vous afin de pouvoir participer !

Vous devez avoir un compte Developpez.com et être connecté pour pouvoir participer aux discussions.

Vous n'avez pas encore de compte Developpez.com ? Créez-en un en quelques instants, c'est entièrement gratuit !

Si vous disposez déjà d'un compte et qu'il est bien activé, connectez-vous à l'aide du formulaire ci-dessous.

Identifiez-vous
Identifiant
Mot de passe
Mot de passe oublié ?
Créer un compte

L'inscription est gratuite et ne vous prendra que quelques instants !

Je m'inscris !

Introduction à ODF::lpOD
Production et exploitation de documents bureautiques OpenOffice et LibreOffice en Perl, par Jean-Marie Gouarné

Le , par jmgdoc

0PARTAGES

1  0 
e mettre en ligne un guide de démarrage en Français sur ODF::lpOD, module de production ou de traitement de documents bureautiques au format ODF (odt, ods, odp, etc). Il est accessible ici.

Une erreur dans cette actualité ? Signalez-le nous !

Avatar de djibril
Responsable Perl et Outils https://www.developpez.com
Le 24/02/2011 à 11:26
Merci pour ce module et cette documentation, je pense que ça en aidera plus d'un.
0  0 
Avatar de djibril
Responsable Perl et Outils https://www.developpez.com
Le 28/02/2011 à 13:00
Le nouvel article de jmgdoc est maintenant disponible dans notre rubrique perl. Il permet de créer ou exploiter facilement des fichiers OpenOffice très facilement en perl.

N'hésitez pas à le lire et des remarques !!

Merci
0  0 
Avatar de djibril
Responsable Perl et Outils https://www.developpez.com
Le 28/02/2011 à 14:55
Ce module permet il la gestion de tous les types de versions d'OpenOffice ?
0  0 
Avatar de jmgdoc
Membre habitué https://www.developpez.com
Le 28/02/2011 à 15:38
Le module ODF::lpOD est compatible avec les versions d'OpenOffice.org à partir de la version 2.0. Ce module est en effet basé sur la spécification OASIS OpenDocument, validée en 2005 et implémentée cette même année par OOo 2.0.

ODF::lpOD est également compatible avec les autres logiciels bureautiques supportant plus ou moins le standard OpenDocument (KOffice, Microsoft Office 2010). Mais attention: ODF::lpOD est utilisable avec tous mais dans certains cas limites le développeur doit tenir compte de divergences d'interprétation du standard.

OpenOffice.org 3.x et LibreOffice 3.x utilisent des extensions par rapport à la spécification OpenDocument, mais cela ne gêne pas. Pour information, ODF::lpOD a été principalement testé avec OpenOffice de 3.0.0 à 3.3.0, et LibreOffice 3.3.1.

En revanche, l'ancien format OpenOffice 1.0 (sxw, sxc, etc...) n'est pas supporté (les utilisateurs qui ont encore à traiter des documents dans ce format en Perl peuvent utiliser OpenOffice::OODoc).
0  0 
Avatar de djibril
Responsable Perl et Outils https://www.developpez.com
Le 28/02/2011 à 15:59
ok, c'est bien de le préciser car ça permet d'éviter d'avoir des soucis de compatibilité. Il serait même peut être intéressant de le rajouter dans le tutoriel.
0  0 
Avatar de djibril
Responsable Perl et Outils https://www.developpez.com
Le 05/11/2012 à 21:37
L'article été mis à jour. Bonne lecture !
0  0