Vous êtes nouveau sur Developpez.com ? Créez votre compte ou connectez-vous afin de pouvoir participer !

Vous devez avoir un compte Developpez.com et être connecté pour pouvoir participer aux discussions.

Vous n'avez pas encore de compte Developpez.com ? Créez-en un en quelques instants, c'est entièrement gratuit !

Si vous disposez déjà d'un compte et qu'il est bien activé, connectez-vous à l'aide du formulaire ci-dessous.

Identifiez-vous
Identifiant
Mot de passe
Mot de passe oublié ?
Créer un compte

L'inscription est gratuite et ne vous prendra que quelques instants !

Je m'inscris !

Quelle version de Perl utilisez-vous ?

Le , par djibril

12PARTAGES

1  0 
Quelle version de Perl utilisez vous principalement ?
Bonjour,

Profitez en pour apporter votre témoignage en précisant pour quelle version vous avez voté, les raisons de ce vote (avantages, inconvénients, contraintes, ...) ainsi que vos intentions pour le proche avenir.

Une erreur dans cette actualité ? Signalez-le nous !

Avatar de djibril
Responsable Perl et Outils https://www.developpez.com
Le 11/12/2008 à 3:42
En ce qui me concerne, j'utilise la version Perl 5.8.8 Built 822. C'est la version la plus à jour des versions Perl 5.8.8.
Je ne suis pas passé pour l'instant à Perl 5.10 car il y a des modules que j'utilise que ne sont pas encore compatible 5.10.
J'arrive à en recompiler certains, mais pas tous.

voilà, à vous
0  0 
Avatar de Arioch
Membre éprouvé https://www.developpez.com
Le 11/12/2008 à 9:14
A la maison :
- 5.8.3 sous Linux Mandriva 2006
- 5.6.1 sous XP

Au taf :
- 5.6.1 sous XP

On a essayé une 5.8.x au boulot une fois, ce fut une horreur : certains scripts ne fonctionnaient plus du tout ou avaient des comportements erratiques hallucinants et dommageables.

On a vite demandé à notre service info de virer cette cochonnerie et on a exigé l'installation d'une 5.6.1 à la place. Tout est rentré dans l'ordre, ouf !
0  0 
Avatar de djibril
Responsable Perl et Outils https://www.developpez.com
Le 11/12/2008 à 10:10
5.6.1 et beh, y a pas moyen de remettre les scripts à jours?
0  0 
Avatar de Arioch
Membre éprouvé https://www.developpez.com
Le 11/12/2008 à 10:36
Citation Envoyé par djibril Voir le message
5.6.1 et beh, y a pas moyen de remettre les scripts à jours?
Trop de scripts à vérifier = Perl 5.6.1 qui fonctionne très bien plutôt qu'une version bancale (pour nous) 5.8.x qui nous obligerait à contrôler quelques dizaines de scripts Perl pour éviter les mauvaises surprises.

Le choix est vite fait
0  0 
Avatar de djibril
Responsable Perl et Outils https://www.developpez.com
Le 11/12/2008 à 10:39
0  0 
Avatar de Jasmine80
Membre émérite https://www.developpez.com
Le 16/12/2008 à 15:57
J'utilise v5.8.8 built for MSWin-x86-multi-thread
Cela va très bien, je changerai quand cette version ne me permettra plus de faire ce que je veux. Mais je dois avouer que je ne suis pas trop à l'aise quand il s'agit de changer quelque chose qui fonctionne, je crains de tout planter et que cela n'aille plus.
0  0 
Avatar de GLDavid
Expert confirmé https://www.developpez.com
Le 15/01/2009 à 8:27
Code : Sélectionner tout
1
2
3
4
5
6
$ perl --version

This is perl, v5.8.8 built for i386-linux-thread-multi

Copyright 1987-2006, Larry Wall
0  0 
Avatar de Z3vil
Membre du Club https://www.developpez.com
Le 15/01/2009 à 11:13
& moi aussi
Code : Sélectionner tout
1
2
3
4
5
6
7
Win32:\>perl --version

This is perl, v5.10.0 built for MSWin32-x86-multi-thread
(with 5 registered patches, see perl -V for more detail)

Copyright 1987-2007, Larry Wall
0  0 
Avatar de djibril
Responsable Perl et Outils https://www.developpez.com
Le 15/01/2009 à 11:51
Utilisez la commande
Code : Sélectionner tout
perl -v

Elle affichera le build
0  0 
Avatar de bioinfornatics
Membre confirmé https://www.developpez.com
Le 28/07/2009 à 9:32
il y a pas perl 6 en proposition
0  0